Cannot play on the Time Slider


Hi, I’ve put together a dashboard and I’m using the Time Slider. I’ve configured the unit steps to days. When I click the play button button I would expect to see data chaging across days (day by day) but nothing happens. This is the AQL in Studio for the Time Slider:

var field = cf.Attribute('refill_date').func('DAY');
var myChart = cf.provider('BigQuery')
                .graph('Time Slider')
                .set('player' ,     { 
                     'step-unit' : 'DAY',
                     'step': 1, 
                     'refresh': 'immediate', 
                    'autoplay': true


I even set the autoplay to true, but nothings happens. Am I missing something?


Hi @jasouvec, probably you are forgetting to select a range (or apply a time filter with the same field used by the Time Slider). We’ve noticed that several people had the same issue so we’ll plan to include some sort of notification or mechanism to prevent this situation. Let me know if that worked for you.


I see, so you need to select a filter first. But then the autoplay shouldn’t automatically trigger the player when I select a filter? I don’t see the purpose of that parameter if I don’t set a filter first.


The autoplay property is useful when you load your app with a filter (it could be a cf.Filter or a time preset) so it will start playing automatically. I recommend you to look into the presets so you can have a better picture.